
IconAnimate Contents

The Contents lists the Help topics available for IconAnimate.    Use the scroll bar to see entries not 
currently visible.

Keyboard
IconAnimate Keys

Commands
Edit Menu
File Menu
Help Menu
Line Menu
Options Menu
Play Menu
Tools Menu
View Menu

Procedures

Adding Content to Icons in the Script
Building Icons into a Script
Clearing Icons
Clearing the Display Surface
Editing the Animation Script
File Naming
Inserting Icons from an Animation File
Loading and Clearing the Image Buffer
Manipulating Graphics
Moving Icons
Opening and Closing the Mouse Position Window
Opening Existing Animation Files
Path Information and IconAnimate
Play Completion Preferences
Playing a Range of Icons
Playing a Single Icon
Playing Selected Icons
Playing the Animation Script
Playing the Entire Script
Play Running Preferences
Play Start Preferences
Quitting IconAnimate
Removing Icons
Repeating Icons
Saving and Renaming Animation Files
Saving Existing Animation Files
Saving New Animation Files
Setting Play Preferences
Starting to Create New Animation Files
Tailoring the IconAnimate Defaults
Using the Display Surface
Using the Image Buffer
Using the Insertion Line
Using the Mouse Pointer to Enter Values
Using the Selection Block
Working with the Tool Box



Zooming the Display Surface



IconAnimate Keys

The following accelerator keys and key combinations are available in IconAnimate:

Menu Command Key(s)

Edit Cut Shift + Delete

Copy Ctrl + Insert

Paste Shift + Insert

Clear Delete

Line Mark for Play Ctrl + M

Disable Selection Ctrl + D

Enable Selection Crtl + E

View Zoom Display Ctrl + Z

Play Run Script Ctrl + R

Within Marked Lines Ctrl + W

Halt Ctrl + H

Additionally, you can use the following keys to perform the corresponding functions:

Key Function

Enter Plays a single line where the play bar is located.    
Also moves the play bar down to the next line.

Shift + Enter Plays a single line where the play bar is located.

Ctrl + down arrow Moves the play bar down one line.

Ctrl + up arrow Moves the play bar up one line.

Ctrl + End Moves the play bar to the end of the script.

Ctrl + Home Moves the play bar to the beginning of the script.

Ctrl + Page Down Moves the play bar down one page of the script.

Ctrl + Page Up Moves the play bar up one page of the script.

End Show the bottom of the script.

Home Show the top of the script.

Page Down Show the next page down in the script.

Page Up Show the next page up in the script.

up arrow Move the insertion pointer up one tool at a time.

down arrow Move the insertion pointer down one tool at a time.



IconAnimate Commands

To get help with a command, choose the appropriate menu.

File Menu
New
Open... 
Save 
Save As... 
Set Path From File...
Exit

Edit Menu
Cut
Copy 
Paste 
Clear 
Copy To... 
Paste From...

Line Menu
Mark For Play
Unmark All Lines
Disable Selection
Enable Selection
Enable All Lines

View Menu
Display Surface
Image Buffer
Tool Box
Mouse Position
Zoom Display
Show Locks
Clear Display Surface
Clear Image Buffer

Play Menu
Run Script
Within Marked Lines
Halt
Play Preferences...

Options Menu
Preferences...

Help Menu
Index
Keyboard 
Commands 
Procedures 
Tools
Using Help 
About IconAnimate... 





IconAnimate Procedures

Editing
Working with the Tool Box
Adding Content to Icons in the Script
Using the Mouse Pointer to Enter Values
Editing the Animation Script
Building Icons into a Script
Clearing Icons
Moving Icons
Removing Icons
Repeating Icons
Inserting Icons from an Animation File
Using the Insertion Line
Using the Selection Block

Managing Files
File Naming
Opening Existing Animation Files
Quitting IconAnimate
Saving and Renaming Animation Files
Saving Existing Animation Files
Saving New Animation Files
Starting to Create New Animation Files
Path Information and IconAnimate

Playing Animation
Playing the Animation Script
Playing a Single Icon
Playing Selected Icons
Playing a Range of Icons
Playing the Entire Script
Play Completion Preferences
Play Running Preferences
Play Start Preferences
Setting Play Preferences

Working with Graphics
Manipulating Graphics
Clearing the Display Surface
Loading and Clearing the Image Buffer
Opening and Closing the Mouse Position Window
Tailoring the IconAnimate Defaults
Using the Display Surface
Using the Image Buffer
Zooming the Display Surface



IconAnimate Tools

Animate Icon
Easel Icon
File Cabinet Icon
Flashlight Icon
Inverted Lock Icon
Lock Icon
Notepad Icon
Paint Roller Icon
Stop Sign Icon
Stop Watch Icon
Transfer Icon
Unlock Icon



Using the Mouse Position Window

The Mouse Position window allows you to view the mouse position coordinates and width/height data as 
you move the mouse across the screen.    This window is used to assist in determining the correct 
coordinates to enter into the various fields of the Content Editor.

By default, the Mouse Position window is not open when you first start IconAnimate.

The title of the Mouse Position window indicates which area of the screen the mouse pointer is currently 
in.    For example, if the mouse pointer is on the Display Surface, then the title will be "Display."    Similarly,
if the mouse pointer is in the Image Buffer window, then the title will be "Buffer." 

The Mouse Position window coordinates are described below:

Position Description

xy The current position of the mouse pointer.

Base The base, or starting location of the mouse pointer.    The base position is set by clicking 
the mouse button.    When this happens the base position is equal to the current (x,y) 
position, and the offset is zero.

wh The width and height of the rectangle with the upper left corner at the base location and 
the lower right corner at the current position of the mouse pointer.

Off The offset, or difference in location, of the current mouse pointer position from the base 
position.

lxy The coordinates (x,y) of the last image to be loaded onto the Display Surface.

lwh The width and height of the last image to be loaded onto the Display Surface.

Related Topic:
Opening and Closing the Mouse Position Window



Opening and Closing the Mouse Position Window

To open the Mouse Position window:

· Choose Mouse Position from the View menu.

To close the Mouse Position window:

· Choose Close from the Control Menu box in the Mouse Position window.
or

· Double click on the Control Menu box.



Working with the Tool Box

The Tool Box Window contains 12 icons, or symbols, that represent the animation functions that are 
available in IconAnimate.    Each icon you select from the Tool Box has a separate and unique function.

Before you begin building the animation script, you must open the Tool Box.    The Tool Box contains 
pictures of each of the icons and can be displayed in two ways.    You can display the Tool Box as a 
window that remains on the screen until you deliberately close it, or you can display it temporarily.    If 
displayed temporarily, the Tool Box is removed when you choose an icon.

To open the Tool Box as a window:
· Choose Tool Box from the View menu.

To close the Tool Box as a window:
· Choose Close from the Control menu in the Tool Box window.

or
· Double Click on the Control menu box in the Tool Box window.

To open the Tool Box temporarily:
· Move the mouse pointer to the Tool Box menu and press the mouse button.    The Tool Box is removed 

when you choose an icon.

The icons are built in a vertical list along the left side of the Animation Script window.    The order in which 
the icons appear along the vertical list is essential, since IconAnimate runs the script by playing the icons 
from top to bottom.    

Related Topic:
Building Icons in a Script



Building Icons into a Script

To place an icon in the animation script:
1. Click on an icon in the Tool Box window.    

The mouse pointer turns into the image of the icon you selected.
2. Place the icon to the left side of the script and click the mouse button.

When you release the mouse button, the icon you selected is present in the script area.
or

1. Open the Tool Box menu by moving the mouse pointer to the Tool Box menu and pressing the mouse 
button.

2. Drag the mouse pointer to the icon you want to select and release the mouse button.
The mouse pointer turns into the image of the icon you selected and the Tool Box disappears.

3. Place the icon to the left side of the script area and click the mouse button.
When you release the mouse button, the icon you selected is present in the script area.

Repeat this process until you select all the icons necessary to create your animation script.    

Once you choose an icon from the Tool Box, you can place it anywhere along the vertical list of icons.    If 
you place the icon at the top of the list, it is added to the top of the script.    If you place the icon at the 
bottom of the list, it is added to the bottom of the script.    If you place the icon on the line separating two 
icons, it is inserted between the two icons.

Related Topic:
Working with the Tool Box



Adding Content to Icons in the Script

Each icon in the Tool Box has a unique Content Editor associated with it.    Although you cannot change 
the basic function that an icon performs, you can add information that allows you to tailor the icon function
to your specific needs.    

You can only display a Content Editor for a particular icon after that icon has been added to the script 
area.

To display a Content Editor:
· Double click on an icon in the script area.

Each Content Editor contains text boxes to which you can assign values, and three command buttons 
labeled OK, Cancel, and Show Script.    

The first text box for each Content Editor is the Comment text box.    

You can enter general information into the Comment text box that briefly describes what the icon does 
when you run the script.    This text can be viewed to the right of each icon in the animation script.    These
comments do not effect the result of the icon function.    

OK button
After you assign values to the Content Editor, click on OK to accept the additions or changes you have 
made and remove the Content Editor.

Cancel button
Click on Cancel to remove the Content Editor without accepting the additions or changes you have made 
and return to the animation script.

Show Script button
The Show Script button is a toggle button.    It allows you to view the animation script while you are 
entering values in the Content Editor, or remove the animation script to view the screen.



Using the Mouse Pointer to Enter Values

You can use the mouse pointer to assign values to Content Editor text boxes that require screen 
coordinates.    The pointer allows you to select locations and areas on the screen by moving the mouse 
and clicking.    When you click, the values are automatically entered in the Content Editor text box.

The text boxes that require screen coordinates are: Location, Width-Height, Buffer Area, Buffer Locations,
Display Locations, Clip Mask, Display Data, and Lock Data.

To use the pointer to enter values:
1. Select a text box that requires screen coordinates by clicking inside the box.    
2. Move the mouse pointer onto the Display Surface or Image Buffer.

The pointer changes to a cross with a rectangle in the lower right quadrant.
Note: To view the location coordinates as the mouse pointer moves, hold down the CTRL key while 
you drag the mouse.

3. Click the mouse button to select a coordinate.
or
Press and hold down the mouse button and drag the mouse to select an area.
or
Click the mouse button at each point of a polygon and then click the mouse button to close the 
polygon.



Editing the Animation Script

Once you have begun to create an animation script, you can either remove, move, repeat or clear icons 
along the vertical animation script.    You can also insert icons into your script that exist in other animation 
files.    

This process is called editing the animation script and involves changing the sequence of the icons.    
When you change the sequence of the icons, you also change the order in which the script is executed.

The tasks of removing, moving and repeating icons are completed by placing icons into a buffer.    A buffer
is a temporary off-screen holding area.    The content of the buffer is replaced when the tasks are 
repeated.    

There are two editing tools that you should become familiar with when editing an animation script: the 
Insertion Line and the Selection Block.

Related Topics:
Removing Icons
Moving Icons
Repeating Icons



Using the Insertion Line

The Insertion Line is a horizontal blinking line that appears between two icons.    This line marks the point 
where icons are inserted into the animation script.    Initially, the Insertion Line appears below the first icon
you build into the animation script.    

You can position the Insertion Line by clicking on an icon.    When you click on an icon, the Insertion Line 
is positioned above that icon.

You can also use the keyboard to move the Insertion Line.

Press this key To get this result

Home Moves the Insertion Line above the first icon.

Up Arrow Moves the Insertion Line up one icon.

Down Arrow Moves the Insertion Line down one icon.

Page Up Moves the Insertion Line up one page.

Page Down Moves the Insertion Line down one page.

End Moves the Insertion Line below the last icon.



Using the Selection Block

The Selection Block is a vertical bar that highlights the icons you want to remove or move in the animation
script.

To select a single icon:
· Click and drag the mouse pointer over the icon you want to select and the Selection Block appears.

To select a group of icons:
1. Press and hold the mouse button on the starting icon.
2. Drag the mouse pointer down over the icons you want to select.
3. Release the mouse button when you have highlighted the ending icon.



Removing Icons

You can remove icons from an animation script by selecting the icons and cutting them with the Cut 
command.

To remove icons from the animation script:
1. Select the icons you want to remove with the Selection Block.
2. Choose the Cut command from the Edit menu or press SHIFT +DEL.

The icons are removed from the animation script.



Moving Icons

You can move icons to another location within the animation script by selecting the icons, removing them 
with the Cut command, and then inserting them with the Paste command.

To move icons from one location to another:
1. Select the icons you want to move with the Selection Block.
2. Choose the Cut command from the Edit menu or press SHIFT + DEL.
3. Position the insertion line at the new position.
4. Choose the Paste command from the Edit menu or press SHIFT + INS.

The icons are inserted at the new position.    



Repeating Icons

You can repeat icons in the animation script by selecting them, copying them with the Copy command, 
and inserting them using the Paste command.

To repeat icons:
1. Select the icons you want to repeat with the Selection Block
2. Choose the Copy command from the Edit menu or press CTRL + INS.

The icons remain unchanged in the animation script and a copy of the icons are placed in the buffer.
3. Position the insertion line at the new position.
4. Choose the Paste command from the Edit menu or press SHIFT + INS.

The icons are inserted at the new position.



Clearing Icons

You can clear icons from the animation script by selecting them and using the Clear command.    Icons 
that are cleared, are removed from the animation script, but are not placed in the buffer.    The current 
content of the buffer is unaffected.

To clear icons:
1. Select the icons you want to clear with the Selection Block.
2. Choose the Clear command from the Edit menu or press DEL.

The icons are removed from the animation script without placing them in the buffer.

Related Topic:
Removing Icons



Inserting Icons from an Animation File

You can insert existing icons from an Animation File into the current file by selecting the insertion point 
and choosing the file to insert.

To insert existing icons from an Animation File:
1. Position the insertion line at the position where you want to insert the file.
2. Choose the Paste From...    command from the Edit menu or press SHIFT + INS.

A File Open dialog box appears.
3. Click on the filename in the list box to select the file to insert.
4. Click on OK to remove the file selection dialog box.

The icons are inserted at the new position.



Playing the Animation Script

There are several ways you can play an animation script.    When you play an animation script you are 
executing the function of an icon or group of icons from the animation script so that it can be viewed from 
the Display Surface.

You can stop the animation script from playing at any time by choosing the Halt command from the Play 
menu or by pressing CTRL + H.

There are play preferences that you can set to tailor the way in which the animation script is played.    
These preferences control what occurs when the animation script starts playing, during the playing and at 
the completion of playing.

Related Topics:
Playing the Entire Script
Playing a Single Icon
Playing a Range of Icons
Playing Selected Icons



Playing the Entire Script

Typically you play the entire script after you have completed it.    Playing the entire script allows you to 
review the final product that the user sees when the animation script is included in an IconAuthor 
application.

To play the entire script:
· Choose the Run Script command from the Play menu or press CTRL + R.

IconAnimate plays the script and returns to the Animation Script window.



Playing a Single Icon

Playing a single icon allows you to check the result of an individual icon.    This is useful when you are still 
building, adding content and editing the animation script.

Note: Some icons depend on the result of previous icons in order for them to play properly.    For 
example, a graphic image must be loaded before it can be animated.    Therefore, the Animate icon 
cannot be played properly as a single icon.

Use the Play Bar to play a single icon.    The play bar is the small bar that appears to the left of the icons.   
The Play Bar marks the current icon to be played.    It appears when you build the first icon into the 
animation script.    The Play Bar can be moved to any icon in the script.

To play a single icon:
1. Place the Play Bar next to the icon you want to play.
2. Double click on the Play Bar.

You can also play a single icon by choosing commands from the Play menu.    Choose the Single Step 
command from the Play menu to play the current icon and move the Play Bar down one icon.    Choose 
the Play Current command from the Play menu to play the current icon, and not move the Play Bar.

While the icon is playing, the Play Bar appears with a ticker cross hatch.    When the icon is finished 
playing, the Play Bar moves down one icon.

You can also use the keyboard to play a single icon.

Press this key To get this result

Return Plays the icon and moves the Play Bar down one icon.

Shift/Return Plays the icon, but does not move the Play Bar.



Playing a Range of Icons

You can play a range of icons in the animation script.    This is useful for reviewing a small portion of your 
script.

To play a range of icons:
1. Select the icons in the range with a selection block. 
2. Choose Mark for Play from the Line menu.

A Play Line appears to the left of the selected icons.    A Play Line is a vertical line that indicates the 
current range of icons to be played.    

3. Choose Within Marked Lines from the Play menu or press CTRL + W.

Note: To remove the Play Line, choose Unmark All Lines from the Line menu.

Only one Play Line can be placed in the animation script at a time.



Playing Selected Icons

You can play any non-consecutive grouping of selected icons.    You play the selected icons by disabling 
the icons you do not want to play.    This is useful when you want to review groups of icons or view the 
result of omitting certain icons.

To play selected icons:
1. Select an icon or icons you want to disable with a Selection Block.
2. Choose Disable Selection from the Line menu or press CTRL + D.

The selected icons are greyed.
3. Repeat steps 1 and 2 for all the icons to disable.
4. Choose Run Script from the Play menu or press CTRL + R.

The icons that have been disabled are not played.

To enable a group of icons, select the icons with a Selection Block and choose Enable Selection from the 
Line menu (or press CTRL +E).

To enable all the icons in the script, choose Enable All Lines from the Line menu.



Setting Play Preferences

You can tailor the way in which the animation script plays by setting the play preferences.    The play 
preferences determine what occurs when the script starts playing, while the script is playing, and when 
the script finishes playing.

To review the play preferences:
· Choose Play Preferences... from the Play menu.

The play preferences are selected from the Play Preferences dialog box.

To select a particular play preference:
· Click on the button next to the desired preference.    

The button is filled in.

To deselect a preference:
· Click on the button next to the preference again.    

The button is no longer filled in.

The play preferences are divided into three categories: Play Start Preferences, Play Running Preferences
and Play Completion Preferences.



Play Start Preferences

These options control the activities when the animation script starts playing.

The Display Surface Zoomed preference causes the Display Surface to zoom to full screen before the 
animation script starts playing.    If the Display Surface Zoomed preference is not selected, the animation 
script remains visible while the animation script is playing.

The Hide Script preference causes the animation script to be removed from the Display Surface before 
the animation script starts playing.    If the Hide Script preference is not selected, the animation script 
remains visible while the animation script is playing.

The Clear Display Surface preference causes the Display Surface to be cleared to black before the 
animation script starts playing.    If the Clear Display Surface preference is not selected, the Display 
Surface remains in its current state when the animation script starts playing.



Play Running Preferences

These options control the activities while the animation script is playing.

The Keep Play Bar in Script preference causes the play bar to step through the icons as the animation 
script is playing.    The Animation Editor window scrolls as the play bar moves down the script.    This is 
useful when you want to view the result of each icon as it occurs.    This preference is only applicable if 
the Hide Script preference is not selected.    If the Keep Play Bar in Script preference is not selected, the 
play bar does not move when the animation script is playing.    The animation script plays faster if the 
Keep Play Bar in Script preference is not selected.

The Display Error Messages preference causes the error messages to be displayed on the screen while 
the animation script is playing.    If the Display Error Messages preference is not selected, the error 
messages are not displayed.

The Loop preference causes the animation script to be played in a loop.    The animation script returns to 
the first icon when the end of the script is reached.    The animation script continues to loop until the Halt 
command is given.    The Halt command can be given by choosing Halt from the Play menu.    If the Loop 
preference is not selected the animation script is played on time.



Play Completion Preferences

These options control the activities after the animation script finishes playing.

The Clear Image Buffer preference causes the Image Buffer to be cleared when the animation script 
finishes playing.    This is useful for freeing system memory resources.    If the Clear Image Buffer 
preference is not selected, the last image remains loaded in the Image Buffer when the animation script 
finishes playing.

The Clear Display Surface preference causes the Display Surface to be cleared to black when the 
animation script finishes playing.    If the Clear Display Surface preference is not selected the Display 
Surface remains in its final state when the animation script finishes playing.



Manipulating Graphics

When you play the animation script the graphic images are displayed either in the Image Buffer or the 
Display Surface, or both.    All graphic images (graphic files) are first loaded into the Image Buffer before 
they can appear on the Display Surface.    The Display Surface can display the entire graphic file image or
portions of the image from the Image Buffer.



Using the Image Buffer

The Image Buffer is a window that serves as a temporary storage buffer for the graphic images being 
displayed.    You load a graphic file into the Image Buffer using the Easel Icon.    Each time you load a 
graphic file into IconAnimate it replaces the contents of the Image Buffer.

The title bar of the Image Buffer contains the name "Image Buffer" and the name of the image (file) 
displayed in the Image Buffer.    If you have not yet loaded a file into the Image Buffer, the title bar 
contains the word "EMPTY."

To open the Image Buffer:
· Choose Image Buffer from the View menu.

To close the Image Buffer:
· Choose Image Buffer from the View menu again.

Related Topics:
Loading and Clearing the Image Buffer



Loading and Clearing the Image Buffer

When a graphic file is loaded into the Image Buffer, it is loaded starting in the upper left corner.    The 
starting location is at the coordinates (0,0).    The size (width and height) of the image in the Image Buffer 
is shown in the title bar.    You use the width and height information to complete some of the Content 
Editor fields.

There are two ways the load a graphic file into the Image Buffer:

To load a graphic file into the Image Buffer.
· Choose the Open command from the Image Buffer File menu when you are creating your animation 

script and want to quickly view a graphic file.
or

· Use the Easel icon when you want to build the display of a graphic file into your animation script.

To clear the Image Buffer:
· Choose Clear Image Buffer from the View menu.

or
· Choose Clear Image Buffer from the Image Buffer File menu.

or
· Select Clear Image Buffer as a Play Completion preference.



Using the Display Surface

The Display Surface is a window where you can view the results of the animation script when it is played. 
The Display Surface can appear as a window on the screen or it can be zoomed to full screen.    When 
the Display Surface is a window you can position it anywhere on the screen.

To open the Display Surface:
· Choose Display Surface from the View menu.

To close the Display Surface:
· Choose Display Surface from the View menu again.

Related Topic:
Clearing the Display Surface



Zooming the Display Surface

Zooming the Display Surface causes the Display Surface to cover the full screen.    This gives you the 
entire screen on which to display images and animation sequences.    If your animation script is going to 
be used in an IconAuthor application, the size of the Display Surface should match the size of the window
in which the IconAuthor application is going to run.    This will ensure that the images appear at the proper 
position on screen, and are not hidden from view.    If the IconAuthor application uses the full screen, it is 
recommended that you zoom the Display Surface during the animation development.

To zoom the Display Surface:
· Choose Zoom Display from the View menu or press CTRL + Z.

To unzoom the Display Surface:
· Choose Zoom Display from the View menu again.

Note: Unzooming the Display Surface restores it to the last size that was less than full screen.



Clearing the Display Surface

It is useful to clear the Display Surface when you want to play one or more icons.    Clearing the Display 
Surface removes any images and makes the Display Surface black.    

To clear the Display Surface:
· Choose Clear Display Surface from the View menu.

or
· Select Clear Display Surface as a Play Completion preference. 



Tailoring the IconAnimate Defaults

You can tailor IconAnimate to automatically open certain windows and select certain options when you 
start up the application.    These defaults are set from the Preferences command in the Options menu.

To tailor the IconAnimate Window defaults:
· Choose Preferences... from the Options menu.

A Preferences dialog box appears.
The first section of the dialog box allows you to determine which windows are initially visible when you 
start the application.    The second section of the dialog box allows you to automatically "turn on" certain 
features when you start the application.

Each default option is listed below along with a description of what happens when the option is selected.   

Display Surface
The Display Surface window is opened automatically when IconAnimate is initially started.

Image Buffer
The Image Buffer is automatically opened when IconAnimate is initially started.

Tool Box
The Tool Box is automatically opened when IconAnimate is initially started.

Mouse Position
The Mouse Position window is automatically opened when IconAnimate is initially started.

Display Surface Zoomed
The Display Surface option causes the Display Surface to automatically zoom to full screen when the 
IconAnimate is initially started.    This option is only available if the Display Surface is selected as a 
window initially visible.

Auto Hide Script
The Auto Hide Script option removes the animation script from the screen each time a Content Editor is 
opened.    Each Content Editor has a Show Script toggle button that allows you to display and remove the 
animation script after you open the Content Editor.    

Show Icon Comments
The Show Icon Comments option displays the comments from the Content Editor next to each icon in the 
animation script.    If this option is not chosen, the icon data are displayed instead.

Show Icon Data
The Show Icon Data option displays the icon data from the Content Editor next to each icon in the 
animation script.    If this option is not chosen, the icon comments are displayed instead.



File Naming

Assign any legal DOS filename to an animation file.    The filename can be one to eight characters plus a 
period and an optional one to three character extension.    If you do not use a filename extension 
IconAnimate automatically adds an .ANI extension.



Saving New Animation Files

The first time you save an animation file you also name it.

To save a new animation file:
1. Choose Save As... from the File menu.

The Save As file selection dialog box appears.
2. Enter the name you want to assign to the graphic file in the Filename text box.
3. Choose OK.

The dialog box is removed and the name of the animation file appears in the title bar.



Saving Existing Animation Files

Periodically, it is a good idea to save changes to an animation file that has been saved previously, but 
now contains unsaved changes.

To save changes to an existing animation file:
· Choose Save from the File menu.

The animation file is saved automatically.



Saving and Renaming Animation Files

It is sometimes useful to save an animation file and rename it at the same time.    For example, you might 
want to make changes to an existing animation file called TRAIN1.ANI, but still keep a copy of it in its 
original state.

You save and rename TRAIN1.ANI, with the name TRAIN2.ANI.    You now have two identical animation 
files with different names.    Make as many changes as you like to TRAIN2.ANI and you will still have a 
copy of the original TRAIN1.ANI.

To save and rename an animation file:
1. Choose Save As... from the File menu.

The Save As file selection dialog box appears.
2. Type the name you want to assign to the animation file in the Filename text box.
3. Choose OK.

The dialog box is removed and the new name of the animation file appears in the title bar.



Starting to Create New Animation Files

When you first start IconAnimate, the Animation Script window is blank.    You can begin building a new 
animation file immediately.

You can also create a new animation file even if you already have an animation script currently visible in 
the window.

To clear the Animation Script window for a new animation file:
· Choose New from the File menu.

The Animation Script window is cleared if the animation file you were working on did not contain 
unsaved changes.
If the animation file contained unsaved changes, a dialog box appears asking if you want to "save the 
current changes" to the file.    To proceed without saving changes choose No.    To save changes 
before proceeding, choose Yes.



Opening Existing Animation Files

To open an animation file:
1. Choose Open... from the File menu.

The Open dialog box appears if a) you just started IconAnimate and the Animation Script window is still
empty, or b) you are working on an animation file that does not contain unsaved changes.
If you are working on a file that contains unsaved changes, a dialog box appears asking if you want to 
"save the current changes" to the file.    To proceed without saving changes choose No.    To save 
changes before proceeding, choose Yes.

2. When the Open dialog box appears, enter the name of the file you want to open in the filename text 
box.

3. Choose OK.
The animation file is opened.



Path Information and IconAnimate

If you are using a customized directory structure to organize the files you create with IconAuthor, 
IconAnimate, and other Editors, you may have to use the Set Path From File...    command in the 
IconAnimate File menu..

When you access IconAnimate, by default, it assumes you are working with files located in the paths 
defined in your master IAUTHOR.PTH file.    If you are creating animation for an application that uses 
paths other than those in IAUTHOR.PTH, choose Set Path From File...    to select an alternative .PTH file 
for IconAnimate to use.    Once you specify an alternative .PTH file, IconAnimate will know where to find 
and store the animation and graphics files for that application.    

Use the Set Path From File...    command as often as necessary.    For example, you may open 
IconAnimate and decide to work on animation used by PROJ1.IW.    Therefore, you choose Set Path 
From File...    and select PROJ1.PTH.    At a later point in time, you decide to work on animation used by 
PROJ2.IW.    The files used by PROJ2.IW are stored in a different group of subdirectories.    Therefore, 
you choose Set Path From File...    again, and select PROJ2.PTH.



Quitting IconAnimate

When you are ready to end your work session, you can quit IconAnimate.

To quit IconAnimate:
· Choose Exit from the File menu.

If you choose exit and have not yet saved the file you are working on, a dialog box appears and asks if
you want to save the changes to the file.

To exit without saving changes:
· Choose No.

To exit and save changes:
1. Choose Yes.

If the file you are saving has been saved (named) on a previous occasion, it is saved automatically.
If the file has not been saved before (it is "untitled"), a Save As file selection dialog box appears.

2. Enter a filename in the Filename text box.
3. Choose OK.

The file is saved and IconAnimate is closed.

Note: When you open IconAnimate from the IconAuthor Display icon Content Editor, work with 
IconAnimate, and close it, the name of the file you last worked on is returned to the Content Editor text 
box from which IconAnimate was started.



Animate Icon

The Animate icon allows you to animate, or move, any portion of the graphic image that is in the Image 
Buffer across the Display Surface.

Suggested Uses:
· Consecutively display the same image at different locations on the screen, causing the image to 

appear as if it is moving.    For example, use this process to make an arrow move across the screen to 
point to a particular area.

· Consecutively display slightly different images at different locations on the screen.    For example, you 
can have a person waving good-bye by animating two or three images, each with the person's hand in 
a different position.

The Animate icon lets you provide the following information:
Comment
Width,Height
Buffer Locations
Display Locations
Smoothness
Speed
Loop Time (sec)
Mask
Color
Polygon
Offset
Remove Last Image
Trail



Comment

Enter comments about the icon.    These comments are displayed next to the icon in the animation script 
area.



Width,Height

Define the size (width and height) of the image that you want to animate.    You can specify the width and 
height of an entire graphic or the width and height of just part of a graphic.    

You can use the mouse or keywords to define this value.    

Acceptable Values:
FULLW, FULLH or valid screen coordinates.

Pop-up List Box Items:
FULLH -- The full height of the last image that was loaded into the Image Buffer.
FULLW -- The full width of the last image that was loaded into the Image Buffer.

As an example, the value FULLH,FULLW defines an image that is the full width and height of the last 
image loaded into the Image Buffer.



Buffer Locations

Load a graphic into the Image Buffer and use this list box to specify the parts of that graphic that you want
to animate.    Specifically, you need to identify the "locations" of rectangular portions that you want to 
animate.    The locations are the coordinates of the upper left corner of each portion you want from the 
Image Buffer.    Use the mouse pointer to select the locations.    

Note: The Image Buffer window must be displayed in order to enter values into the Buffer Locations text 
box.

Specify more than one buffer location if the graphic file that you loaded into the Image Buffer contains 
multiple images that you want to use in your animation.    

Each time a display is made, the Animate icon uses the image that is at the location listed next in the 
Buffer Locations field.    When the list is expired, the Animate icon goes back to the first location listed.    
This allows you to display different versions of an image in a sequence.    For example, five versions of a 
boat, each with waves drawn in different positions, displayed in sequence, will make the boat appear to 
be sailing.

Acceptable Values:
Valid screen coordinates.



Display Locations

List the locations where the upper left corner of the images being animated appear on the Display 
Surface.    Use the mouse pointer to select the locations.

Specify more than one location if you want the image to move across the screen as it is displayed.    For 
example, you can make the boat sail across a lake and back again.    You enter the starting location and 
then each of the following locations, thus defining the path that you want to boat to take.    The Animate 
icon displays the image in a straight line path between each of the points that you specify.    You do not 
have to enter all the points along the path where you want the image to appear.    The Animate icon 
automatically displays the image at points along the path that it calculates based on the value in the 
Smoothness text box.

Acceptable Values:
Valid screen coordinates.



Smoothness

Specify a keyword or a number that denotes the degree of smoothness or coarseness you want in your 
animation.    To select a keyword double click in the Smoothness text box.    A list box appears with the 
valid keywords.    Click on a keyword and choose OK.

If the Smoothness value is blank or zero the image will be displayed at each of the locations listed in the 
Display Locations text box without any intermediate points.        The recommended value for this field is 
between 0 and 5.

Acceptable Values:
A whole number (such as 3 or 5), a keyword, or a variable.



Speed

Specify a keyword or a number that denotes the speed with which you want the animation to play.    To 
select a keyword double click in the Speed box.    A list box appears with a list of the valid keywords.    
Click on a keyword and choose OK.    

If this field is blank or zero, the animation sequence will go as fast as possible.    A whole number indicates
the number of milliseconds between each actual display point on the straight path between selected 
Display Locations.    As an example, 250 (ms) causes a 1/4 second pause between each display of an 
image being animated.

The VeryFast keyword is the only one value that is CPU-dependent.    The other values will run at the 
same speed on all systems.

Acceptable Values:
A whole number, a keyword, or a variable.



Loop Time (sec) 

Define the total time for which the animation sequence will run.    This value is typically specified when an 
object is being animated in one location.    If this field is blank, then the Animate icon will run one time from
start to finish (until the Display Location coordinates have been exhausted).    If the time specified is 
longer than the time necessary for the Animate icon to finish, then the animation sequence will loop back 
to the beginning and continue until the time expires.    If the time specified is shorter than the time 
necessary for the Animate icon to finish, then the animation sequence will be cut off before it finishes.

Acceptable Values:
A real number (such as 3 or 7.2) or a variable.



Coordinate Masking

A key feature of the Animate icon is its ability to let you mask a part of the graphic in the Image Buffer to 
make animation on the Display Surface appear more realistic.    Masking is the process of hiding 
unwanted portions of an image you are animating.    The Transparency area of the Animate icon Content 
Editor lets you choose from one of three masking methods: color masking, coordinate masking, or 
polygon masking.        

Use the Mask text box to do coordinate masking.

When you use coordinate masking you create a specially designed graphic that contains its own mask.    
This kind of graphic actually contains two side-by-side images: the image you want to animate on the left 
and a mask for that image on the right.    This masking method is recommended when color masking 
cannot be used, that is, when all of the solid colors in your palette are present in the graphic being 
animated.    (This leaves no color available to be specified as transparent.)

In the Width,Height field you specify the width an height of just the image on the left half of the graphic.    
In the Buffer Locations list box you specify on location 0,0.    In the Mask box, you specify the coordinates 
of the point that is the upper left corner of the mask.

Acceptable Values:
Valid screen coordinates or a variable.



Color Masking

A key feature of the Animate icon is its ability to let you mask a part of the graphic in the Image Buffer to 
make animation on the Display Surface appear more realistic.    Masking is the process of hiding 
unwanted portions of an image you are animating.    The Transparency area of the Animate icon Content 
Editor lets you choose from one of three masking methods: color masking, coordinate masking, or 
polygon masking.        

Use the Color text box to do color masking.

When you perform color masking you specify a particular color you want to make transparent when the 
Animate icon executes.

Acceptable Values:
A keyword, an RGB value, or a variable.

Valid Keywords:
Double click in the Color box to display the Color Names dialog box.    When you choose a color the 
corresponding name is returned to the Color box.

If the color you want to use does not appear in the Color Names dialog box, choose Set Custom Color to 
display the Custom Color dialog box.    Adjust the slider bars as desired and choose OK to close the 
dialog box.    Choose OK in the Color Names dialog box and the RGB value is automatically returned to 
the Content Editor field.



Polygon Masking

A key feature of the Animate icon is its ability to let you mask a part of the graphic in the Image Buffer to 
make animation on the Display Surface appear more realistic.    Masking is the process of hiding 
unwanted portions of an image you are animating.    The Transparency area of the Animate icon Content 
Editor lets you choose from one of three masking methods: color masking, coordinate masking, or 
polygon masking.        

Use the Polygon list box to do polygon masking.

When you perform polygon masking you draw a polygon around the object or objects (in the Image 
Buffer) that you want to animate.

To create a polygon mask:
1. Load the image to be animated into the Image Buffer.
2. Build and open an Animate icon.
3. Fill in all the necessary data in fields other than the Transparency area.
4. Click in the Polygon list box.
5. Move the cursor to the Image Buffer.
6. Click on a point on the perimeter of the object you are animating.
7. Click on another point on the perimeter of the object to draw an imaginary line that begins to surround 

the object.
8 Continue clicking on points on the perimeter until you almost completely surround the object.
9. Double click to close the surrounding polygon.

The coordinates of the points that you selected are entered in the Polygon list box.

The polygon masking process varies slightly depending on the type of animation you are creating.    Some
general rules:

· To animate one object across the screen, draw a simple mask as described above.
· To animate multiple versions of one object, draw a separate mask around each pose (double clicking 

to complete each mask).
· To animate multiple versions of one object (where each image object is the same shape and size in 

each pose), draw a polygon mask around the first object and turn on the Offset check box.    This 
causes IconAnimate to use the same mask for each version of the object.



Offset

When you turn on the Offset box IconAnimate uses the same polygon mask for each image that is part of 
the animation.    The idea is that you can use the same mask repeatedly since the object is the same 
shape and size in each pose.    This option is only used for Polygon Masking.



Remove Last Image

Select the Remove Last Image check box to remove from the Display Surface the last image displayed 
during the animation sequence.    If this box is not selected, the last image in the animation sequence 
remains on the screen.



Trail

Select the Trail option to cause a portion of each image that is displayed as part of the animation to 
remain on the screen.



Easel Icon

The Easel icon allows you to load a graphic file into the Image Buffer and optionally display it on the 
Display Surface

Suggested Uses:
· Load a graphic file into the Image Buffer to transfer portions of the image to the Display Surface.
· Load a graphic file into the Image Buffer to animate the image.
· Display the entire graphic file directly onto the Display Surface.

The Easel icon lets you provide the following information:
Comment
File Type
Name
Display Surface
Display Data
Location
Effect,Modifier,Speed Options



File Type

Define the type of graphic file you want to load.    The default value is Bitmap.

Acceptable Values:
Bitmap, Pm Meta.

Pop-up List Box Items:
bitmap - Indicates that you want to print a bitmap graphic, such as a file created with IconAuthor's Graphic
Editor or Microsoft Paintbrush.    Select this item if you are loading a graphic with a .PCX, .BMP, or .RLE 
extension.

pm meta - Indicates that you want to load a Pagemaker meta file, created with Aldus Pagemaker.    Like 
the Windows Metafile, Pagemaker files also use a .WMF extension.



Name

Select the filename of the graphic image (file) you want to load.    Double click in the Name text box to 
display a file selection dialog box that contains a directory listing of graphic files.    The filenames are 
taken from the current directory.

Acceptable Values:
A filename with a .PCX, .BMP, .RLE, or .WMF extension.



Display Surface 

Click on the Display Surface check box to transfer the image in the graphic file to the Display Surface.



Display Data

The Location and Effect,Modifier,Speed text boxes under the Display Data heading require values only 
when the Display Surface check box is selected.    These boxes define where the graphic file appears on 
the Display Surface, and how it is displayed.



Location 

Use the Location text box to define where the graphic file appears on the Display Surface, and how it is 
displayed.    You can use the mouse or keywords to define this value.

Acceptable Values:
CENTERED, LASTX, LASTY or valid screen coordinates.

Pop-up List Box Items:
CENTERED -- Locates the image in the center of the screen, either horizontally or vertically, depending 
on which coordinate you substitute with the keyword CENTERED.

LASTX -- The X coordinate of the last image that was placed on the Display Surface.

LASTY -- The Y coordinate of the last image that was placed on the Display Surface.

As an example, the value CENTERED,CENTERED positions the image at the center of the screen.    
CENTERED,150 positions the image horizontally in the center of the screen and down 150 pixels.    
LASTX,LASTY positions the top left corner of the image in the same location as the previously displayed 
image.



Effect,Modifier,Speed

Select the Effect, Modifier, and Speed options for the graphic effect you want to use to display the 
graphic.

Double click on the Effect Options text box to display the Effect Options dialog box.

Effect Defines the type of effect used when the image is placed onto the Display Surface.    The 
Modifier and Speed options are dependent on the Effect option you select.

Modifier Defines the direction in which the effect occurs.    The available modifier changes 
depending on the effect you select.

Speed Defines the speed at which the effect occurs.    A real number for speed can be entered 
by selecting the Use Custom Speed check box and entering a number into the Custom 
Speed text box.    Refer to the end of this chapter for numeric equivalents to the speed 
keywords.    The speed of the effect will be impacted by the size of the graphic image 
being displayed.



File Cabinet Icon

The File Cabinet icon allows you to run a previously created animation script file from within another 
animation script.

Suggested Uses:
· Combine multiple animation scripts into one script.
· Combining several short animation scripts using the File Cabinet icon makes the animation scripts 

easier to manage.

The File Cabinet icon lets you provide the following information:
Comment
File Name



Filename

Specify the name of the animation script file that you want to run.    Double click on the Filename text box 
to display a directory listing of animation script files.

It is the convention of IconAnimate to specify a file extension of .ANI for animation files.

Acceptable Values:
A valid IconAnimate filename.



Flashlight Icon

The Flashlight icon allows you to flash an area of the Display Surface on and off.    The flashed area can 
be any shape and can be the entire area or only the border.

Suggested Uses:
· Flash an area on the Display Surface to highlight images or text on the screen to catch the viewers 

attention.

The Flashlight icon lets you provide the following information:
Comment
Flash Type
Border Flash
Border Width
Display Data
Number of Flashes
Total Time (sec)
Flash Rate
Last Image Inverted



Flash Type

Specify the type of region you want to flash.    The flash type can be an ellipse, a polygon or a rectangle.

Acceptable Values:
ELLIPSE, POLYGON, RECTANGLE.

Pop-up List Box Items:
ELLIPSE -- The values specify the upper left corner and the width and height of the rectangle that is the 
boundary of the ellipse.

POLYGON -- The values specify the coordinates of the points that are the corners of the polygon.

RECTANGLE -- The values specify the upper left corner and the width and height of the rectangle.



Border Flash

Select the Border Flash option to flash only the border of the area specified.    You specify the width of the 
border in the Border Width text box.



Border Width

Specify the width of the border you want to flash.    The values indicate the width of the border in pixels.    
This field is only valid when the Border Flash button is selected.

Acceptable Values:
A real number (such as 5 or 25).



Display Data

Specify the areas on the Display Surface you want to flash.    The required values change depending on 
the flash type you selected.    You can use the mouse or choose keywords to select the flash areas.

Acceptable Values:
LASTX,LASTY,LASTW or valid screen coordinates.

Pop-up List Box Items:
LASTX -- The X coordinate of the last image that was placed on the Display Surface.

LASTY -- The Y coordinate of the last image that was placed on the Display Surface.

LASTW -- The width of the last image that was placed on the Display Surface.



Number of Flashes

Specify the number of times the display area flashes.    The area flashes for the number of flashes 
specified unless a value is entered in the Total Time text box.    If both values are specified, then the area 
flashes for whatever action is completed first, either the number or the time.

Acceptable Values:
A real number (such as 5 or 15).



Total Time (Sec) 

Specify the number of seconds the area flashes.    A decimal value can be entered in this text box.    The 
area flashes for the total time specified unless a value is entered in the Number of Flashes text box.    If 
both values are specified, then the area flashes for whatever action is completed first, either the number 
or the time.

Acceptable Values:
A real number (such as 2.5 or 10).



Flash Rate

Specify the speed of the flash.    Double click on the Flash Rate text box to display a selection box of 
keywords.    You can enter your own numeric value or select a keyword.    Numeric values are in 
milliseconds, therefore a value of 1000 results in a one second flash.

Acceptable Values:
VERYSLOW, SLOW, MEDIUM, FAST, VERYFAST or a real number (such as 1000 or 3000).

Pop-up List Box Items:
VERYSLOW, SLOW, MEDIUM, FAST, VERYFAST



Last Image Inverted

Select the Last Image Inverted check box to specify the status of the flashed areas when the flash is 
complete.    If the Last Image Inverted check box is selected, the areas are inverted, or reverse highlighted
when the flashing is complete.    If the Last Image Inverted check box is not selected, the areas return to 
the normal color when the flashing is complete.

To invert an area on the Display Surface, without a flash, specify zero for the number of flashes and select
the Last Image Inverted check box.    The areas become inverted, or reverse highlighted.



Inverted Lock Icon

The Inverted Lock icon allows you to reverse the locked and unlocked regions on the Display Surface.    
Essentially, the locked regions on the Display Surface become unlocked and the unlocked regions on the 
Display Surface become locked.

Suggested Uses:
· Lock a full screen area around a single object on the Display Surface.    

The File Cabinet icon lets you provide the following information:
Comment

To use this icon, build it into your animation script.    When you play the script and the icon is executed, 
the current state of all existing locks is inverted.



Lock Icon

The Lock icon allows you to lock an area on the Display Surface so that nothing can be displayed in that 
area until the area is unlocked.    This icon is typically used to give an object a sense of depth or 
dimension.

Suggested Use:
· Lock an area on the screen and then move an object across that area.    The object appears to go 

behind the locked area.    For example, your display includes some trees on an island in the middle of 
a lake and you are animating a sailboat traveling across the lake, behind the island.    You can lock the 
tops of the trees so the sailboat appears to go behind them.

The Lock icon lets you provide the following information:
Comment
Lock Type
Lock Data



Lock Type

Specify the type of region to lock.    The lock type can be an ellipse, polygon or rectangle.    Select the lock
type from the pop-up list box.

 Acceptable Values:
ELLIPSE, POLYGON, RECTANGLE. 

Pop-up List Box Items:
ELLIPSE - (X,Y,W,H) - The values specify the upper left corner and the width and height of the rectangle 
that is the boundary of the ellipse.    

POLYGON- (X,Y) - The values specify the coordinates of the points that are the corners of the polygon.    

RECTANGLE - (X,Y,W,H) - The values specify the upper left corner and the width and height of the 
rectangle.



Lock Data

Specify the areas on the Display Surface to be locked.    The data required changes depending on the 
lock type selected.    You can use the mouse pointer to select the locations on the Display Surface or 
select keywords from a pop-up list box.

Double click in the Lock Data text box to display a selection box.

Acceptable Values:
LASTX, LASTY, LASTW, LASTH or valid screen coordinates.

Pop-up List Box Items:
LASTX - The X coordinate of the last image that was placed on the Display Surface.

LASTY -- The Y coordinate of the last image that was placed on the Display Surface.

LASTW -- The width of the last image that was placed on the Display Surface.

LASTH -- The height of the last image that was placed on the Display Surface.



Notepad Icon

The Notepad icon allows you to store notes in the animation script.

Suggested Use:
· Add a brief description of the function and purpose of the animation script.

Use the Comment Window to enter free form text to save as notes and comments about the animation 
script.    



Paint Roller Icon

The Paint Roller icon allows you to paint (display) a color onto the Display Surface or load a color into the 
Image Buffer.

Suggested Uses:
· Display a color directly onto the Display Surface to clear the screen at the beginning or between 

portions of an animation script.
· Remove an image from the screen by painting over it.
· Load a color area into the Image Buffer to animate a colored rectangle or square.

The Paint Roller icon lets you provide the following information:
Comment
Width,Height
Color Value
Display Surface
Display Data
Location
Effect,Modifier,Speed



Width,Height

Define the size, or width and height of the area to be painted.    You can use the mouse pointer to define a
portion of the screen to paint, or you can select the FULLSCREEN keyword to paint the full screen.

Acceptable Values:
FULLSCREEN or valid screen coordinates.

Pop-up List Box Items:
FULLSCREEN Defines the width and height of the area to be the full screen and thus the entire screen is
painted.



Color Value

Specify the color you want to paint.    You specify the color by using color names or by specifying the 
intensity of the three primary colors: Red, Green, Blue.    Each of the primary colors is assigned a value 
between 0 and 255.    0 is the lowest intensity; 255 is the highest intensity.

Double click in the Color Value text box to display the Color Names dialog box.    You can select a 
predefined color or customize a color.

To select a predefined color:
1. Click on the desired color box, color button or color name.

The button is filled with black to indicate it has been selected.
2. Click on the OK button to return to the Content Editor.

To customize a color:
1. Click on the Set Custom Color button.

The Custom Color window appears.
2. Press and hold the mouse button on the white indicator box inside the slide bar and drag the box to 

change the color intensity level.
The new color intensity value is shown above the color slide bar.    The resulting color is displayed in 
the large area below the slide bar.

3. Continue to change the color intensities of red, green and blue until the desired color is created.
4. Click on OK to accept the selected color and return to the Content Editor.



Display Surface

Click on the Display Surface check box to paint the selected color directly to the Display Surface.    If the 
Display Surface check box is not selected, then only the Image Buffer is painted with the selected color.

If the Display Surface is painted without a specified effect, then the content of the Image Buffer is not 
affected.    When painting the Display Surface, you do not have to reload graphic files into the Image 
Buffer.



Display Data

The Location and Effect,Modifier,Speed text boxes under the Display Data heading require values only 
when the Display Surface check box is selected.    These boxes define where the graphic file appears on 
the Display Surface, and how it is displayed.



Location

Use the Location text box to define where the graphic file appears on the Display Surface, and how it is 
displayed.    You can use the mouse or keywords to define this value.

Acceptable Values:
CENTERED, LASTX, LASTY or valid screen coordinates.

Pop-up List Box Items:
CENTERED -- Locates the image in the center of the screen, either horizontally or vertically, depending 
on which coordinate you use for the effect keyword.

LASTX -- The X coordinate of the last image that was placed on the Display Surface.

LASTY -- The Y coordinate of the last image that was on the Display Surface.

As an example, CENTERED,CENTERED positions the image at the center of the screen.    
CENTERED,150 positions the image horizontally in the center of the screen and down 150 pixels.    
LASTX,LASTY positions the top left corner of the image in the same location as the previously displayed 
image.



Effect,Modifier,Speed

Use the Effect,Modifier,Speed text box to select the Effect, Modifier, and Speed options for the graphic 
effect you want to use to display the graphic.    Double click in the text box to display the Effect Options 
dialog box.

You can specify the following items in the Effect Options dialog box:

Effect Defines the action used when the Display Surface is painted.    The Modifier and Speed 
options are dependent on the Effect option you select.

Modifier Defines the direction in which the effect occurs.    The available modifier changes 
depending on the effect you select.

Speed Defines the speed at which the effect occurs.    A real number for speed can be entered 
by selecting the Use Custom Speed check box and entering a number into the Custom 
Speed text box.    Refer to the end of this chapter for numeric equivalents to the speed 
keywords.    The speed of the effect will be impacted by the size of the graphic image 
being displayed.



Stop Sign Icon

The Stop Sign icon allows you to stop the animation script at any point during the animation and resume 
the animation when a specified event has occurred.

Suggested Use:
· Stop the animation periodically to allow the viewer to control the pace of the script.

The Stop Sign icon lets you provide the following information:
Comment
Mouse Button is Clicked
Key is Hit
Timeout Seconds



Mouse Button is Clicked

Select the Mouse Button is Clicked button to stop the animation script until the viewer clicks a mouse 
button.    



Key Is Hit

Select the Key Is Hit button to stop the animation script until the viewer hits any key on the keyboard.



Timeout Seconds

Specify a timeout period in seconds.    If the event specified does not occur within the time out period, 
then the animation script automatically continues.    Any decimal number can be entered in this field.    If 
you want the animation script to wait for a mouse click or a keyboard entry, then leave this field blank.

Acceptable Values:
A real number (greater than 0, such as 5 or 15).

Note: The Stop Sign icon options can be selected in any combination.    The event that occurs first causes
the animation script to continue.



Stop Watch Icon

The Stop Watch icon allows you to stop the animation script and pause for a specified time period.

Suggested Uses:
· Stop the animation during a tutorial to allow the viewer ample time to comprehend the instructions.

The Stop Watch icon lets you provide the following information:
Comment
Seconds

Use the Seconds text box to specify the number of seconds you want the animation script to pause.

Acceptable Values:
A real number (greater than 0, such as 1.5 or 5).



Transfer Icon

The Transfer icon allows you to transfer a portion of the graphic image that is in the Image Buffer to the 
Display Surface.

Suggested Uses:
· Transfer multiple images from a single graphic file to the Display Surface at different times, with 

different display effects, and at locations other than the original location.

The Transfer icon lets you provide the following information:
Comment
Buffer Area
Display Data
Location
Effect,Modifier,Speed



Buffer Area

Define the image, or a portion of the image in the Image Buffer that you want to transfer to the Display 
Surface.    The Buffer Area is defined by the location of the upper left corner of the image in the Image 
Buffer, and the width and height of the image in the Image Buffer.    You can use the mouse or keywords 
to define the image you want to transfer.    If you use the mouse to define the image, the Image Buffer 
window must be displayed.

Acceptable Values:
FULLW, FULLH or valid screen coordinates.

Pop-up List Box Items:
FULLW -- The full width of the last image that was loaded into the Image Buffer.

FULLH -- The full height of the last image that was loaded into the Image Buffer.

As an example, 0,0,FULLW,FULLH defines the image whose upper left corner is at the coordinates (0,0) 
and has the same width and height as the previously loaded image.    These particular values define the 
entire Image Buffer.



Display Data

The Location and Effect,Modifier,Speed text boxes under the Display Data heading define where the 
graphic file appears on the Display Surface, and how it is displayed.



Location 

Define where the graphic file appears on the Display Surface and how it is displayed.    You can use the 
mouse or keywords to define this value.

Acceptable Values:
CENTERED, LASTX, LASTY or valid screen coordinates.

Pop-up List Box Items:
CENTERED -- Locates the image in the center of the screen, either horizontally or vertically, depending 
on which coordinate you use the keyword for.

LASTX -- The X coordinate of the last image that was placed on the Display Surface.

LASTY -- The Y coordinate of the last image that was on the Display Surface.

As an example, CENTERED,CENTERED positions the image at the center of the screen.    
CENTERED,150 positions the image horizontally in the center of the screen and down 150 pixels.    
LASTX,LASTY positions the top left corner of the image in the same location as the previously displayed 
image.



Effect,Modifier,Speed

Use the Effect,Modifier,Speed Options text box to select the Effect, Modifier, and Speed options for the 
graphic effect you want to use to display the graphic.    Double click on the Effect,Modifier,Speed text box 
to display the Effect Options dialog box.

You can specify the following items in the Effect Options dialog box:

Effect Defines the action used when the Display Surface is painted.    The Modifier and Speed 
options are dependent on the Effect option you select.

Modifier Defines the direction in which the effect occurs.    The available modifier changes 
depending on the effect you select.

Speed Defines the speed at which the effect occurs.    A real number for speed can be entered 
by selecting the Use Custom Speed check box and entering a number into the Custom 
Speed text box.    Refer to the end of this chapter for numeric equivalents to the speed 
keywords.    The speed of the effect will be impacted by the size of the graphic image 
being displayed.



Unlock Icon

The Unlock icon allows you to unlock an area on the Display Surface so that an image can be displayed 
at that location.    This icon should be placed on the script sometime after the Lock icon.

Suggested Use:
· Unlock an area on the screen that was previously locked so that subsequent images can be displayed 

on the screen area.

The Unlock icon lets you provide the following information:
Comment
Lock Type
Lock Data



Lock Type

Specify the type of region to unlock.    The lock type can be an ellipse, polygon or rectangle.    Select the 
lock type from the pop-up list box.

Acceptable Values:
ELLIPSE, POLYGON, RECTANGLE 

Pop-up List Box Items:
ELLIPSE - (X,Y,W,H) - The values specify the upper left corner and the width and height of the rectangle 
that is the boundary of the ellipse.    

POLYGON- (X,Y) - The values specify the coordinates of the points that are the corners of the polygon.    

RECTANGLE - (X,Y,W,H) - The values specify the upper left corner and the width and height of the 
rectangle.    



Lock Data

Specify the areas on the Display Surface to be unlocked.    The data required changes depending on the 
lock type selected.    You can use the mouse pointer to select the locations on the Display Surface or 
select keywords from a pop-up list box.

Double click in the Lock Data text box to display a selection box.

Acceptable Values:
LASTX, LASTY, LASTW, LASTH or valid screen coordinates.

Pop-up List Box Items:
LASTX - The X coordinate of the last image that was placed on the Display Surface.

LASTY -- The Y coordinate of the last image that was placed on the Display Surface.

LASTW -- The width of the last image that was placed on the Display Surface.

LASTH -- The height of the last image that was placed on the Display Surface.



File Menu

New
Clears the current screen and lets you start a new animation script.

Related Topic:
Starting to Create New Animation Files

Open... 
Opens an existing animation file.

Related Topic:
Opening Existing Animation Files

Save 
Saves an existing animation file with the same name.

Related Topic:
Saving Existing Animation Files

Save As... 
Allows you to save and name an animation file for the first time, or to save and rename an existing 
animation file.

Related Topic:
Saving and Renaming Animation Files

Set Path From File...
Causes IconAnimate to read the .PTH file of an IconAuthor application.    The .PTH file tells IconAnimate 
where the animation and graphic files for that application are located.

Related Topic:
Path Information and IconAnimate

Exit
Exits IconAnimate.    Lets you save unsaved changes before quitting.

Related Topic:
Quitting IconAnimate



Edit Menu

Cut
Removes the selected icons from the animation script and puts them into a private paste buffer, separate 
from the Windows Clipboard.

Related Topic:
Removing Icons

Copy
Places a copy of the selected icons in the animation script and puts them into a private paste buffer, 
separate from the Windows Clipboard

Related Topic:
Repeating Icons

Paste
Places the icons from the paste buffer into the animation script.      The pasted icons appear below the 
Insertion Line.Related Topic:

Repeating Icons

Clear
Clears or removes the selected icons from the animation script without placing them in the paste buffer.

Related Topic:
Clearing Icons

Paste From...
Places a copy of the contents of an animation file into the animation script.      Select the animation file you
want to insert in the current animation script from the File Open dialog box.

Related Topic:
Inserting Icons from an Animation File



Line Menu

Mark For Play
Marks the selected icons for play.      A green or grey Play Line appears to the left of the icons that are 
marked for play.      Only one play line can be placed in the animation script at a time.

Related Topic:
Playing Selected Icons

Unmark All Lines
Removes the play line from the animation script.

Related Topic:
Playing the Animation Script

Disable Selection
Disables the selected icons in the animation script.      These icons are not played when the animation 
script is executed.

Related Topic:
Playing the Animation Script

Enable Selection
Enables the selected icons in the animation script.

Enable All Lines
Enables all the icons in the animation script that were previously marked as disabled.



View Menu

Display Surface
Causes the Display Surface window to appear on the screen.

Related Topic:
Using the Display Surface

Image Buffer
Causes the Image Buffer window to appear on the screen.

Related Topic:
Using the Image Buffer

Tool Box
Causes the Tool Box window to appear on the screen.

Related Topic:
Working with the Tool Box

Mouse Position
Causes the Mouse Position window to appear on the screen.

Related Topic:
Using the Mouse Position Window

Zoom Display
Zooms the Display Surface to full screen.

Related Topic:
Zooming the Display Surface

Show Locks
Shows the locked areas on the Display Surface.

Related Topic:
Lock Icon

Clear Display Surface
Clears the Display Surface to black.

Related Topic:
Clearing the Display Surface

Clear Image Buffer
Clears the contents of the Image Buffer.

Related Topic:
Loading and Clearing the Image Buffer



Tools Menu

The Tools menu displays the IconAnimate Tool Box window.

Related Topics:
Animate Icon
Easel Icon
File Cabinet Icon
Flashlight Icon
Inverted Lock Icon
Lock Icon
Notepad Icon
Paint Roller Icon
Stop Sign Icon
Stop Watch Icon
Transfer Icon
Unlock Icon



Play Menu

Run Script
Plays the entire animation script.

Related Topic:
Playing the Entire Script

Within Marked Lines
Plays the icons in the animation script that are marked with the Play Line.

Halt
Stops the execution of an animation script.      Halt is available only when an animation script is playing.

Related Topic:
Playing the Animation Script

Play Preferences...
Displays the Play Preferences dialog box.

Related Topic:
Setting Play Preferences



Options Menu

Preferences...
Allows you to select window defaults and options that execute when you initially start IconAnimate.

Related Topic:
Tailoring the IconAnimate Defaults



Help Menu

Index
Displays an alphabetical list of all Help topics that are available.

Keyboard 
Displays the accelerators for performing some tasks with the keyboard instead of the mouse.

Commands 
Displays an explanation of commands.

Procedures 
Displays a description of how to use IconAnimate.

Tools 
Displays a description of each icon and its function.

Using Help 
Displays a short tutorial and other information about using Windows on-line Help.

About IconAnimate... 
Displays IconAnimate copyright and version information.




